Details
-
Improvement
-
Status: Resolved
-
Major
-
Resolution: Fixed
-
None
-
None
Description
I find the static variable names verbose. I think it's clear from context that they refer to the Kinesis configuration since they are all gathered in that class.
Therefore would like to remove the CONFIG_ prefix before the release, so that we have
conf.put(KinesisConfigConstants.AWS_REGION, "")
instead of
conf.put(KinesisConfigConstants.CONFIG_AWS_REGION, "")
For longer variables it becomes even longer otherwise.
—
Some basic variable names that might be accessed frequently are also very long:
CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_SECRETKEY CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_ACCESSKEYID
It might suffice to just have:
AWS_SECRET_KEY AWS_ACCESS_KEY
Attachments
Issue Links
- links to