Description
As discussed here [1] we should rethink the nameing of the NodeState and related classes.
I suggest the following renaming:
NodeState -> NodeData
PropertyState -> PropertyData
TransientNodeState -> NodeState
KernelNodeState -> KernelNodeData
My reasoning: the current NodeState and PropertyState classes are immutable (and thus
represent pure values i.e. data). The word state implies mutability
(after all OOP is about mutation of state all over) so renaming
TransientNodeState to NodeState should make sense. Also the oak API will
be more publicly visible than the lower level MK API. So having catchy
names there is a plus.