Description
FeedbackMessages method public final FeedbackMessage first(int level) has documentation specifying that it "Retrieves the first message matching the specified level" when in fact it calls FeedbackMessage's isLevel(int level) which "Returns whether this level is greater than or equal to the given level." which is also poorly named as it doesn't return whether the FeedbackMessage is of the specified level; it returns if it's of the specified level or more severe.
In my opinion both the current functionality and the functionality to return only those messages of a specified level are desirable. A minimal solution is an update to the documentation of FeedbackMessage's first(int level) method but I think the methods should be renamed to say what they actually do.