Description
OFFactory is really a bad name and I think that LifecycleManager sounds much better
So the proposed renames include:
package: org.apache.wink.common.internal.factory -> org.apache.wink.common.internal.lifecycle
class: DefaultOFFactory -> DefaultLifecycleManager
class: OFFactory -> LifecycleManager
class: OFFactoryRegistry ->LifecycleManagerRegistry
class: ScopeOFFactory -> ScopeLifecycleManager
class: SpringOFFactory -> SpringLifecycleManager
class: SpringOFFactoryPostProcessor - > LifecycleManagerPostProcessor
The ObjectFactory interface and its implementing classes remain unchanged.
So in general the idea is: LifecycleManager is responsible to return ObjectFactory.
I'm not so good in naming, so any comments will be appreciated